Nuovo aggiornamento di sicurezza per Drupal

Nuovo aggiornamento di sicurezza per Drupal

Negli ultimi tempi il Content Manager System Drupal sta costringendo i suoi utilizzatori a continui aggiornamenti, appena qualche settimana fa erano state rese disponibili la maintenance releases numero 6.11 e 5.17, ora è il turno delle 6.12 e 5.18.

Come nel caso precedente, anche le ultimissime versioni dell'applicazione sono state riviste e corrette a causa di una vulnerabilità; l'ultima falla rilevata avrebbe permesso infatti di lanciare da remoto attacchi di tipo XSS (Cross site scripting) con cui pregiudicare il livello di sicurezza dei siti basati su questo CMS.

Il problema, classificato come moderatamente critico (ma non per questo da sottovalutare), riguarda alcune stringhe di byte che, assolutamente innocue se interpretate secondo lo standard UTF-8, avrebbero potuto causare problemi tramite Internet Explorer 6 e 7 se interpretate secondo lo standard UTF-7.

L'exploit praticabile tramite questa falla non sembra però essere stato utilizzato, nè al momento si hanno notizie di siti Web Drupal-based o database caduti sotto i colpi perpetrati approfittando della vulnerabilità; in ogni caso un aggiornamento è d'obbligo per questioni di sicurezza.

I commenti degli utenti

I commenti sono sottoposti alle linee guida di moderazione e prima di essere visibili devono essere approvati da un moderatore.

Commenti

I commenti sono sottoposti alle linee guida di moderazione e prima di essere visibili devono essere approvati da un moderatore.